aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build22
1 files changed, 9 insertions, 13 deletions
diff --git a/meson.build b/meson.build
index fbd9752a..75e06e3d 100644
--- a/meson.build
+++ b/meson.build
@@ -3,7 +3,7 @@ project(
3 'c', 3 'c',
4 version: '1.4', #release_version 4 version: '1.4', #release_version
5 license: 'MIT', 5 license: 'MIT',
6 meson_version: '>=0.48.0', 6 meson_version: '>=0.53.0',
7 default_options: [ 7 default_options: [
8 'c_std=c11', 8 'c_std=c11',
9 'warning_level=2', 9 'warning_level=2',
@@ -292,18 +292,14 @@ if get_option('fish-completions')
292 install_data(fish_files, install_dir: fish_install_dir) 292 install_data(fish_files, install_dir: fish_install_dir)
293endif 293endif
294 294
295status = [ 295summary({
296 '', 296 'xwayland': have_xwayland,
297 'Features:', 297 'gdk-pixbuf': gdk_pixbuf.found(),
298 'xwayland: @0@'.format(have_xwayland), 298 'systemd': systemd.found(),
299 'gdk-pixbuf: @0@'.format(gdk_pixbuf.found()), 299 'elogind': elogind.found(),
300 'systemd: @0@'.format(systemd.found()), 300 'tray': have_tray,
301 'elogind: @0@'.format(elogind.found()), 301 'man-pages': scdoc.found(),
302 'tray: @0@'.format(have_tray), 302}, bool_yn: true)
303 'man-pages: @0@'.format(scdoc.found()),
304 '',
305]
306message('\n'.join(status))
307 303
308if not systemd.found() and not elogind.found() 304if not systemd.found() and not elogind.found()
309 warning('The sway binary must be setuid when compiled without (e)logind') 305 warning('The sway binary must be setuid when compiled without (e)logind')