summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 2a020323..d5b33e6b 100644
--- a/meson.build
+++ b/meson.build
@@ -12,6 +12,7 @@ project(
12add_project_arguments('-Wno-unused-parameter', language: 'c') 12add_project_arguments('-Wno-unused-parameter', language: 'c')
13add_project_arguments('-Wno-unused-function', language: 'c') 13add_project_arguments('-Wno-unused-function', language: 'c')
14add_project_arguments('-Wno-unused-result', language: 'c') 14add_project_arguments('-Wno-unused-result', language: 'c')
15add_project_arguments('-DWL_HIDE_DEPRECATED', language: 'c')
15add_project_arguments('-DWLR_USE_UNSTABLE', language: 'c') 16add_project_arguments('-DWLR_USE_UNSTABLE', language: 'c')
16 17
17cc = meson.get_compiler('c') 18cc = meson.get_compiler('c')
@@ -205,3 +206,14 @@ if (get_option('bash_completions'))
205 206
206 install_data(bash_files, install_dir: bash_install_dir) 207 install_data(bash_files, install_dir: bash_install_dir)
207endif 208endif
209
210if (get_option('fish_completions'))
211 fish_files = files(
212 'completions/fish/sway.fish',
213 'completions/fish/swaylock.fish',
214 'completions/fish/swaymsg.fish',
215 )
216 fish_install_dir = datadir + '/fish/completions'
217
218 install_data(fish_files, install_dir: fish_install_dir)
219endif