summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f27ac451..b681f43a 100644
--- a/meson.build
+++ b/meson.build
@@ -27,7 +27,10 @@ wayland_client = dependency('wayland-client')
27wayland_egl = dependency('wayland-egl') 27wayland_egl = dependency('wayland-egl')
28wayland_protos = dependency('wayland-protocols') 28wayland_protos = dependency('wayland-protocols')
29xkbcommon = dependency('xkbcommon') 29xkbcommon = dependency('xkbcommon')
30cairo = dependency('cairo')
30pango = dependency('pango') 31pango = dependency('pango')
32pangocairo = dependency('pangocairo')
33gdk_pixbuf = dependency('gdk-pixbuf-2.0', required: false)
31pixman = dependency('pixman-1') 34pixman = dependency('pixman-1')
32libcap = dependency('libcap') 35libcap = dependency('libcap')
33libinput = dependency('libinput') 36libinput = dependency('libinput')
@@ -35,6 +38,12 @@ math = cc.find_library('m')
35git = find_program('git', required: false) 38git = find_program('git', required: false)
36a2x = find_program('a2x', required: false) 39a2x = find_program('a2x', required: false)
37 40
41conf_data = configuration_data()
42
43if gdk_pixbuf.found()
44 conf_data.set('HAVE_GDK_PIXBUF', true)
45endif
46
38if a2x.found() 47if a2x.found()
39 mandir = get_option('mandir') 48 mandir = get_option('mandir')
40 man_files = [ 49 man_files = [
@@ -85,9 +94,13 @@ add_project_arguments('-DSWAY_VERSION=@0@'.format(version), language: 'c')
85 94
86sway_inc = include_directories('include') 95sway_inc = include_directories('include')
87 96
97subdir('include')
98subdir('protocols')
88subdir('common') 99subdir('common')
89subdir('sway') 100subdir('sway')
90subdir('swaymsg') 101subdir('swaymsg')
102subdir('client')
103subdir('swaybg')
91 104
92config = configuration_data() 105config = configuration_data()
93config.set('sysconfdir', join_paths(prefix, sysconfdir)) 106config.set('sysconfdir', join_paths(prefix, sysconfdir))