aboutsummaryrefslogtreecommitdiffstats
path: root/common/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build21
1 files changed, 16 insertions, 5 deletions
diff --git a/common/meson.build b/common/meson.build
index abe0cdcf..01736ca6 100644
--- a/common/meson.build
+++ b/common/meson.build
@@ -1,12 +1,23 @@
1lib_sway_common = static_library('sway-common', 1deps = [
2 cairo,
3 wlroots
4]
5
6if gdk_pixbuf.found()
7 deps += [gdk_pixbuf]
8endif
9
10lib_sway_common = static_library(
11 'sway-common',
2 files( 12 files(
13 'cairo.c',
14 'ipc-client.c',
3 'log.c', 15 'log.c',
4 'list.c', 16 'list.c',
5 'util.c',
6 'stringop.c',
7 'readline.c', 17 'readline.c',
8 'ipc-client.c' 18 'stringop.c',
19 'util.c'
9 ), 20 ),
10 dependencies: [ wlroots ], 21 dependencies: deps,
11 include_directories: sway_inc 22 include_directories: sway_inc
12) 23)