summaryrefslogtreecommitdiffstats
path: root/common/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/common/meson.build b/common/meson.build
new file mode 100644
index 00000000..44a29508
--- /dev/null
+++ b/common/meson.build
@@ -0,0 +1,23 @@
1lib_sway_common = static_library(
2 'sway-common',
3 files(
4 'background-image.c',
5 'cairo.c',
6 'ipc-client.c',
7 'log.c',
8 'list.c',
9 'pango.c',
10 'readline.c',
11 'stringop.c',
12 'unicode.c',
13 'util.c'
14 ),
15 dependencies: [
16 cairo,
17 gdk_pixbuf,
18 pango,
19 pangocairo,
20 wlroots
21 ],
22 include_directories: sway_inc
23)