summaryrefslogtreecommitdiffstats
path: root/common/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build21
1 files changed, 9 insertions, 12 deletions
diff --git a/common/meson.build b/common/meson.build
index 4ad47077..44a29508 100644
--- a/common/meson.build
+++ b/common/meson.build
@@ -1,17 +1,7 @@
1deps = [
2 cairo,
3 pango,
4 pangocairo,
5 wlroots
6]
7
8if gdk_pixbuf.found()
9 deps += [gdk_pixbuf]
10endif
11
12lib_sway_common = static_library( 1lib_sway_common = static_library(
13 'sway-common', 2 'sway-common',
14 files( 3 files(
4 'background-image.c',
15 'cairo.c', 5 'cairo.c',
16 'ipc-client.c', 6 'ipc-client.c',
17 'log.c', 7 'log.c',
@@ -19,8 +9,15 @@ lib_sway_common = static_library(
19 'pango.c', 9 'pango.c',
20 'readline.c', 10 'readline.c',
21 'stringop.c', 11 'stringop.c',
12 'unicode.c',
22 'util.c' 13 'util.c'
23 ), 14 ),
24 dependencies: deps, 15 dependencies: [
16 cairo,
17 gdk_pixbuf,
18 pango,
19 pangocairo,
20 wlroots
21 ],
25 include_directories: sway_inc 22 include_directories: sway_inc
26) 23)