summaryrefslogtreecommitdiffstats
path: root/common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'common/CMakeLists.txt')
-rw-r--r--common/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/common/CMakeLists.txt b/common/CMakeLists.txt
index 95617e15..38767249 100644
--- a/common/CMakeLists.txt
+++ b/common/CMakeLists.txt
@@ -1,5 +1,4 @@
1add_library(sway-common 1add_library(sway-common
2 ${SWAY_Backtrace_HEADER}
3 ipc-client.c 2 ipc-client.c
4 list.c 3 list.c
5 log.c 4 log.c
@@ -7,3 +6,10 @@ add_library(sway-common
7 readline.c 6 readline.c
8 stringop.c 7 stringop.c
9 ) 8 )
9
10if(Backtrace_FOUND)
11 set_target_properties(sway-common
12 PROPERTIES
13 COMPILE_FLAGS "-include ${Backtrace_HEADER}"
14 )
15endif()