summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ea0e3648..74c79075 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,9 +47,11 @@ option(enable-swaymsg "Enables the swaymsg utility" YES)
47option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES) 47option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES)
48option(zsh-completions "Zsh shell completions" NO) 48option(zsh-completions "Zsh shell completions" NO)
49option(default-wallpaper "Installs the default wallpaper" YES) 49option(default-wallpaper "Installs the default wallpaper" YES)
50set(LD_LIBRARY_PATH "/usr/lib" CACHE STRING "Configures sway's default LD_LIBRARY_PATH") 50option(LD_LIBRARY_PATH "Configure sway's default LD_LIBRARY_PATH")
51 51
52add_definitions(-D_LD_LIBRARY_PATH="${LD_LIBRARY_PATH}") 52if (LD_LIBRARY_PATH)
53 add_definitions(-D_LD_LIBRARY_PATH="${LD_LIBRARY_PATH}")
54endif()
53 55
54find_package(JsonC REQUIRED) 56find_package(JsonC REQUIRED)
55find_package(PCRE REQUIRED) 57find_package(PCRE REQUIRED)