summaryrefslogtreecommitdiffstats
path: root/swaylock/meson.build
diff options
context:
space:
mode:
authorLibravatar emersion <contact@emersion.fr>2019-01-14 08:57:20 +0100
committerLibravatar GitHub <noreply@github.com>2019-01-14 08:57:20 +0100
commit89ad3f2bbbb6f5f367387992eea5d5c6f7fa7642 (patch)
tree2ef2485e9a103b9850219b7cf6375e48b20b72b5 /swaylock/meson.build
parentRemove WIP from README.md (diff)
parentSplit swaylock into separate project (diff)
downloadsway-89ad3f2bbbb6f5f367387992eea5d5c6f7fa7642.tar.gz
sway-89ad3f2bbbb6f5f367387992eea5d5c6f7fa7642.tar.zst
sway-89ad3f2bbbb6f5f367387992eea5d5c6f7fa7642.zip
Merge pull request #3417 from swaywm/remove-swaylock
Split swaylock into separate project
Diffstat (limited to 'swaylock/meson.build')
-rw-r--r--swaylock/meson.build55
1 files changed, 0 insertions, 55 deletions
diff --git a/swaylock/meson.build b/swaylock/meson.build
deleted file mode 100644
index f3321a78..00000000
--- a/swaylock/meson.build
+++ /dev/null
@@ -1,55 +0,0 @@
1sysconfdir = get_option('sysconfdir')
2
3dependencies = [
4 cairo,
5 client_protos,
6 gdk_pixbuf,
7 math,
8 pango,
9 pangocairo,
10 xkbcommon,
11 wayland_client,
12 wlroots,
13]
14
15sources = [
16 'main.c',
17 'password.c',
18 'render.c',
19 'seat.c'
20]
21
22if libpam.found()
23 sources += ['pam.c']
24 dependencies += [libpam]
25else
26 warning('The swaylock binary must be setuid when compiled without libpam')
27 warning('You must do this manually post-install: chmod a+s /path/to/swaylock')
28 sources += ['shadow.c']
29 if crypt.found()
30 dependencies += [crypt]
31 endif
32endif
33
34executable('swaylock',
35 sources,
36 include_directories: [sway_inc],
37 dependencies: dependencies,
38 link_with: [lib_sway_common, lib_sway_client],
39 install_rpath : rpathdir,
40 install: true
41)
42
43if is_freebsd
44 install_data(
45 'pam/swaylock.freebsd',
46 install_dir: sysconfdir + '/pam.d/',
47 rename: 'swaylock'
48 )
49else
50 install_data(
51 'pam/swaylock.linux',
52 install_dir: sysconfdir + '/pam.d/',
53 rename: 'swaylock'
54 )
55endif