summaryrefslogtreecommitdiffstats
path: root/swaylock/meson.build
diff options
context:
space:
mode:
authorLibravatar sghctoma <sghctoma@gmail.com>2018-08-30 09:58:57 +0200
committerLibravatar sghctoma <sghctoma@gmail.com>2018-08-30 09:58:57 +0200
commit6de777a986e1b8d38e5030106f2abb937eca6232 (patch)
tree2fd9292d719ddb849e3a244c567fe9015524848d /swaylock/meson.build
parentFix SYSCONFDIR to include "prefix" (diff)
downloadsway-6de777a986e1b8d38e5030106f2abb937eca6232.tar.gz
sway-6de777a986e1b8d38e5030106f2abb937eca6232.tar.zst
sway-6de777a986e1b8d38e5030106f2abb937eca6232.zip
Add FreeBSD-specific PAM configuration
The "login" PAM configuration means somathing entirely different on FreeBSD than on Linux: if you try to authenticate as the calling user, it OKs the request without prompting for password. The "passwd" config implements the desired functionality, therefore it should be used by swaylock.
Diffstat (limited to 'swaylock/meson.build')
-rw-r--r--swaylock/meson.build17
1 files changed, 13 insertions, 4 deletions
diff --git a/swaylock/meson.build b/swaylock/meson.build
index 63f694b9..675b8c69 100644
--- a/swaylock/meson.build
+++ b/swaylock/meson.build
@@ -24,7 +24,16 @@ executable(
24 install: true 24 install: true
25) 25)
26 26
27install_data( 27if is_freebsd
28 'pam/swaylock', 28 install_data(
29 install_dir: sysconfdir + '/pam.d/' 29 'pam/swaylock.freebsd',
30) 30 install_dir: sysconfdir + '/pam.d/',
31 rename: 'swaylock'
32 )
33else
34 install_data(
35 'pam/swaylock.linux',
36 install_dir: sysconfdir + '/pam.d/',
37 rename: 'swaylock'
38 )
39endif