summaryrefslogtreecommitdiffstats
path: root/swaylock/meson.build
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2018-04-12 20:19:54 -0400
committerLibravatar Drew DeVault <sir@cmpwn.com>2018-04-12 20:19:54 -0400
commitcd1b32453a9296c18b28bff71607aeb22987b5cd (patch)
treec653c6d525b471914c01a9d7ae543f521b6138ed /swaylock/meson.build
parentMerge pull request #1634 from aleksander/master (diff)
parentFix separator height calculation (diff)
downloadsway-cd1b32453a9296c18b28bff71607aeb22987b5cd.tar.gz
sway-cd1b32453a9296c18b28bff71607aeb22987b5cd.tar.zst
sway-cd1b32453a9296c18b28bff71607aeb22987b5cd.zip
Merge branch 'wlroots'
Diffstat (limited to 'swaylock/meson.build')
-rw-r--r--swaylock/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/swaylock/meson.build b/swaylock/meson.build
new file mode 100644
index 00000000..3cde47a4
--- /dev/null
+++ b/swaylock/meson.build
@@ -0,0 +1,23 @@
1executable(
2 'swaylock', [
3 'main.c',
4 'password.c',
5 'render.c',
6 'seat.c'
7 ],
8 include_directories: [sway_inc],
9 dependencies: [
10 cairo,
11 client_protos,
12 gdk_pixbuf,
13 libpam,
14 math,
15 pango,
16 pangocairo,
17 xkbcommon,
18 wayland_client,
19 wlroots,
20 ],
21 link_with: [lib_sway_common, lib_sway_client],
22 install: true
23)