summaryrefslogtreecommitdiffstats
path: root/swaylock/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Nuew <code@nuew.net>2016-03-24 18:02:34 -0400
committerLibravatar Nuew <code@nuew.net>2016-03-24 18:02:34 -0400
commit0aa4383c9a1b3b693ee771e7829ed84582b4577c (patch)
tree4bc6746cabaedeae60ffeeb0f082c4c850487062 /swaylock/CMakeLists.txt
parentMerge pull request #537 from mikkeloscar/exit-on-config-missing (diff)
downloadsway-0aa4383c9a1b3b693ee771e7829ed84582b4577c.tar.gz
sway-0aa4383c9a1b3b693ee771e7829ed84582b4577c.tar.zst
sway-0aa4383c9a1b3b693ee771e7829ed84582b4577c.zip
Add choice of display to --image.
Additionally - Made background colors display when an image is enabled if a --color is specified. - Link CJson to swaylock. - Add the --socket option to swaylock.
Diffstat (limited to 'swaylock/CMakeLists.txt')
-rw-r--r--swaylock/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/swaylock/CMakeLists.txt b/swaylock/CMakeLists.txt
index 08c893ca..b290cd2f 100644
--- a/swaylock/CMakeLists.txt
+++ b/swaylock/CMakeLists.txt
@@ -4,6 +4,7 @@ include_directories(
4 ${CAIRO_INCLUDE_DIRS} 4 ${CAIRO_INCLUDE_DIRS}
5 ${PANGO_INCLUDE_DIRS} 5 ${PANGO_INCLUDE_DIRS}
6 ${PAM_INCLUDE_DIRS} 6 ${PAM_INCLUDE_DIRS}
7 ${JSONC_INCLUDE_DIRS}
7) 8)
8 9
9add_executable(swaylock 10add_executable(swaylock
@@ -18,6 +19,7 @@ target_link_libraries(swaylock
18 ${CAIRO_LIBRARIES} 19 ${CAIRO_LIBRARIES}
19 ${PANGO_LIBRARIES} 20 ${PANGO_LIBRARIES}
20 ${PAM_LIBRARIES} 21 ${PAM_LIBRARIES}
22 ${JSONC_LIBRARIES}
21 m 23 m
22) 24)
23 25