aboutsummaryrefslogtreecommitdiffstats
path: root/swayidle/meson.build
diff options
context:
space:
mode:
authorLibravatar Brian Ashworth <RedSoxFan@users.noreply.github.com>2018-05-14 00:28:21 -0400
committerLibravatar GitHub <noreply@github.com>2018-05-14 00:28:21 -0400
commit34b864fb1752fde2528db6aa86d53c23412a8f43 (patch)
treeb387f1e1eb8f8fc16faeb4bf24a0ab6e8ba5787c /swayidle/meson.build
parentFix titles and detect edges for hide_edge_borders (diff)
parentActually fix swayidle (diff)
downloadsway-34b864fb1752fde2528db6aa86d53c23412a8f43.tar.gz
sway-34b864fb1752fde2528db6aa86d53c23412a8f43.tar.zst
sway-34b864fb1752fde2528db6aa86d53c23412a8f43.zip
Merge branch 'master' into fix-1975
Diffstat (limited to 'swayidle/meson.build')
-rw-r--r--swayidle/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/swayidle/meson.build b/swayidle/meson.build
new file mode 100644
index 00000000..f62545f8
--- /dev/null
+++ b/swayidle/meson.build
@@ -0,0 +1,18 @@
1threads = dependency('threads')
2
3executable(
4 'swayidle', [
5 'main.c',
6 ],
7 include_directories: [sway_inc],
8 dependencies: [
9 client_protos,
10 pixman,
11 wayland_client,
12 wayland_server,
13 wlroots,
14 swayidle_deps,
15 ],
16 link_with: [lib_sway_common, lib_sway_client],
17 install: true
18)