summaryrefslogtreecommitdiffstats
path: root/swayidle/meson.build
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2019-01-12 09:40:09 -0500
committerLibravatar Brian Ashworth <bosrsf04@gmail.com>2019-01-12 11:24:06 -0500
commitbc808680b173d5a3c4732265b33e2e8bd81e4d9b (patch)
tree800d9f0ba88f37c2dd35aae09fcdbec91c0532c3 /swayidle/meson.build
parentMerge pull request #3411 from RedSoxFan/fix-brace-detect-seeking (diff)
downloadsway-bc808680b173d5a3c4732265b33e2e8bd81e4d9b.tar.gz
sway-bc808680b173d5a3c4732265b33e2e8bd81e4d9b.tar.zst
sway-bc808680b173d5a3c4732265b33e2e8bd81e4d9b.zip
Split swayidle from sway
Diffstat (limited to 'swayidle/meson.build')
-rw-r--r--swayidle/meson.build27
1 files changed, 0 insertions, 27 deletions
diff --git a/swayidle/meson.build b/swayidle/meson.build
deleted file mode 100644
index 79d2c5c4..00000000
--- a/swayidle/meson.build
+++ /dev/null
@@ -1,27 +0,0 @@
1threads = dependency('threads')
2
3swayidle_deps = [
4 client_protos,
5 pixman,
6 wayland_client,
7 wayland_server,
8 wlroots,
9]
10
11if systemd.found()
12 swayidle_deps += systemd
13endif
14if elogind.found()
15 swayidle_deps += elogind
16endif
17
18executable(
19 'swayidle', [
20 'main.c',
21 ],
22 include_directories: [sway_inc],
23 dependencies: swayidle_deps,
24 link_with: [lib_sway_common, lib_sway_client],
25 install_rpath : rpathdir,
26 install: true
27)