summaryrefslogtreecommitdiffstats
path: root/swaygrab/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2017-12-01 08:21:01 -0500
committerLibravatar GitHub <noreply@github.com>2017-12-01 08:21:01 -0500
commit1cfebe827ae53a243ffdd1e09f8b71d4c1a4e254 (patch)
treeb74002984ff80201c02ed9c22ca2fe1cdae98e23 /swaygrab/CMakeLists.txt
parentMerge pull request #1482 from acrisci/refactor/use-frame-done (diff)
parentupdate travis (diff)
downloadsway-1cfebe827ae53a243ffdd1e09f8b71d4c1a4e254.tar.gz
sway-1cfebe827ae53a243ffdd1e09f8b71d4c1a4e254.tar.zst
sway-1cfebe827ae53a243ffdd1e09f8b71d4c1a4e254.zip
Merge pull request #1479 from acrisci/feature/meson-build
meson build
Diffstat (limited to 'swaygrab/CMakeLists.txt')
-rw-r--r--swaygrab/CMakeLists.txt28
1 files changed, 0 insertions, 28 deletions
diff --git a/swaygrab/CMakeLists.txt b/swaygrab/CMakeLists.txt
deleted file mode 100644
index 42806cae..00000000
--- a/swaygrab/CMakeLists.txt
+++ /dev/null
@@ -1,28 +0,0 @@
1include_directories(
2 ${JSONC_INCLUDE_DIRS}
3 ${WLC_INCLUDE_DIRS}
4 ${XKBCOMMON_INCLUDE_DIRS}
5)
6
7add_executable(swaygrab
8 main.c
9 json.c
10)
11
12target_link_libraries(swaygrab
13 sway-common
14 ${JSONC_LIBRARIES}
15 rt
16 m
17)
18
19install(
20 TARGETS swaygrab
21 RUNTIME
22 DESTINATION bin
23 COMPONENT runtime
24)
25
26if (A2X_FOUND)
27 add_manpage(swaygrab 1)
28endif()