aboutsummaryrefslogtreecommitdiffstats
path: root/swaybg/meson.build
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2018-03-28 15:25:33 -0400
committerLibravatar GitHub <noreply@github.com>2018-03-28 15:25:33 -0400
commit9070950eecded7bfa64e7bca3bb76b150ccc8b72 (patch)
tree509a9c669bf2679085e27a1ff1b0c95526abf14c /swaybg/meson.build
parentMerge pull request #1641 from swaywm/transformed-events (diff)
parentAddress review comments (diff)
downloadsway-9070950eecded7bfa64e7bca3bb76b150ccc8b72.tar.gz
sway-9070950eecded7bfa64e7bca3bb76b150ccc8b72.tar.zst
sway-9070950eecded7bfa64e7bca3bb76b150ccc8b72.zip
Merge pull request #1638 from swaywm/swaybg-layers
Reimplement swaybg using surface layers
Diffstat (limited to 'swaybg/meson.build')
-rw-r--r--swaybg/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/swaybg/meson.build b/swaybg/meson.build
new file mode 100644
index 00000000..5e10f3c7
--- /dev/null
+++ b/swaybg/meson.build
@@ -0,0 +1,18 @@
1executable(
2 'swaybg',
3 'main.c',
4 include_directories: [sway_inc],
5 dependencies: [
6 cairo,
7 gdk_pixbuf,
8 jsonc,
9 math,
10 pango,
11 pangocairo,
12 sway_protos,
13 wayland_client,
14 wlroots,
15 ],
16 link_with: [lib_sway_common, lib_sway_client],
17 install: true
18)