aboutsummaryrefslogtreecommitdiffstats
path: root/swaybg/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2017-12-01 08:21:01 -0500
committerLibravatar GitHub <noreply@github.com>2017-12-01 08:21:01 -0500
commit1cfebe827ae53a243ffdd1e09f8b71d4c1a4e254 (patch)
treeb74002984ff80201c02ed9c22ca2fe1cdae98e23 /swaybg/CMakeLists.txt
parentMerge pull request #1482 from acrisci/refactor/use-frame-done (diff)
parentupdate travis (diff)
downloadsway-1cfebe827ae53a243ffdd1e09f8b71d4c1a4e254.tar.gz
sway-1cfebe827ae53a243ffdd1e09f8b71d4c1a4e254.tar.zst
sway-1cfebe827ae53a243ffdd1e09f8b71d4c1a4e254.zip
Merge pull request #1479 from acrisci/feature/meson-build
meson build
Diffstat (limited to 'swaybg/CMakeLists.txt')
-rw-r--r--swaybg/CMakeLists.txt37
1 files changed, 0 insertions, 37 deletions
diff --git a/swaybg/CMakeLists.txt b/swaybg/CMakeLists.txt
deleted file mode 100644
index f8cad404..00000000
--- a/swaybg/CMakeLists.txt
+++ /dev/null
@@ -1,37 +0,0 @@
1include_directories(
2 ${PROTOCOLS_INCLUDE_DIRS}
3 ${WAYLAND_INCLUDE_DIR}
4 ${CAIRO_INCLUDE_DIRS}
5 ${PANGO_INCLUDE_DIRS}
6 ${XKBCOMMON_INCLUDE_DIRS}
7)
8
9add_executable(swaybg
10 main.c
11)
12
13target_link_libraries(swaybg
14 sway-common
15 sway-wayland
16 ${WAYLAND_CLIENT_LIBRARIES}
17 ${WAYLAND_CURSOR_LIBRARIES}
18 ${CAIRO_LIBRARIES}
19 ${PANGO_LIBRARIES}
20 m
21)
22
23if (WITH_GDK_PIXBUF)
24 include_directories(
25 ${GDK_PIXBUF_INCLUDE_DIRS}
26 )
27 target_link_libraries(swaybg
28 ${GDK_PIXBUF_LIBRARIES}
29 )
30endif()
31
32install(
33 TARGETS swaybg
34 RUNTIME
35 DESTINATION bin
36 COMPONENT runtime
37)