summaryrefslogtreecommitdiffstats
path: root/swaybg/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2015-11-12 19:04:01 -0500
committerLibravatar Drew DeVault <sir@cmpwn.com>2015-11-12 19:04:01 -0500
commitbfcabe48ef3fc7a0388de007504fc232f826fb84 (patch)
tree8bef61a10259765dbafed49c9a2a76b4bf9ced2d /swaybg/CMakeLists.txt
parentMerge branch 'master' of github.com:SirCmpwn/sway (diff)
downloadsway-bfcabe48ef3fc7a0388de007504fc232f826fb84.tar.gz
sway-bfcabe48ef3fc7a0388de007504fc232f826fb84.tar.zst
sway-bfcabe48ef3fc7a0388de007504fc232f826fb84.zip
Start fleshing out wayland client implementation
This introduces a basic shared framework for making wayland clients within sway itself.
Diffstat (limited to 'swaybg/CMakeLists.txt')
-rw-r--r--swaybg/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/swaybg/CMakeLists.txt b/swaybg/CMakeLists.txt
index 89d8afde..9351441a 100644
--- a/swaybg/CMakeLists.txt
+++ b/swaybg/CMakeLists.txt
@@ -9,14 +9,20 @@ WAYLAND_ADD_PROTOCOL_CLIENT(proto-xdg-shell "xdg-shell.xml" xdg-shell)
9 9
10set(CMAKE_RUNTIME_OUTPUT_DIRECTORY "../bin/") 10set(CMAKE_RUNTIME_OUTPUT_DIRECTORY "../bin/")
11include_directories( 11include_directories(
12 ${CMAKE_CURRENT_SOURCE_DIR}/include 12 ${CMAKE_CURRENT_SOURCE_DIR}/../include
13 ${WAYLAND_CLIENT_INCLUDE_DIR} 13 ${WAYLAND_CLIENT_INCLUDE_DIR}
14 ${CAIRO_INCLUDE_DIRS} 14 ${CAIRO_INCLUDE_DIRS}
15 ${PANGO_INCLUDE_DIRS} 15 ${PANGO_INCLUDE_DIRS}
16) 16)
17 17
18FILE(GLOB sources ${PROJECT_SOURCE_DIR}/*.c)
19FILE(GLOB wl_sources ${PROJECT_SOURCE_DIR}/../wayland/*.c)
20FILE(GLOB common ${PROJECT_SOURCE_DIR}/../common/*.c)
21
18add_executable(swaybg 22add_executable(swaybg
19 main.c 23 ${sources}
24 ${wl_sources}
25 ${common}
20) 26)
21 27
22TARGET_LINK_LIBRARIES(swaybg ${WAYLAND_CLIENT_LIBRARIES} ${CAIRO_LIBRARIES} ${PANGO_LIBRARIES}) 28TARGET_LINK_LIBRARIES(swaybg ${WAYLAND_CLIENT_LIBRARIES} ${CAIRO_LIBRARIES} ${PANGO_LIBRARIES})