summaryrefslogtreecommitdiffstats
path: root/swaybar/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2018-04-12 20:19:54 -0400
committerLibravatar Drew DeVault <sir@cmpwn.com>2018-04-12 20:19:54 -0400
commitcd1b32453a9296c18b28bff71607aeb22987b5cd (patch)
treec653c6d525b471914c01a9d7ae543f521b6138ed /swaybar/CMakeLists.txt
parentMerge pull request #1634 from aleksander/master (diff)
parentFix separator height calculation (diff)
downloadsway-cd1b32453a9296c18b28bff71607aeb22987b5cd.tar.gz
sway-cd1b32453a9296c18b28bff71607aeb22987b5cd.tar.zst
sway-cd1b32453a9296c18b28bff71607aeb22987b5cd.zip
Merge branch 'wlroots'
Diffstat (limited to 'swaybar/CMakeLists.txt')
-rw-r--r--swaybar/CMakeLists.txt51
1 files changed, 0 insertions, 51 deletions
diff --git a/swaybar/CMakeLists.txt b/swaybar/CMakeLists.txt
deleted file mode 100644
index 48ededdd..00000000
--- a/swaybar/CMakeLists.txt
+++ /dev/null
@@ -1,51 +0,0 @@
1include_directories(
2 ${PROTOCOLS_INCLUDE_DIRS}
3 ${WAYLAND_INCLUDE_DIR}
4 ${CAIRO_INCLUDE_DIRS}
5 ${PANGO_INCLUDE_DIRS}
6 ${JSONC_INCLUDE_DIRS}
7 ${XKBCOMMON_INCLUDE_DIRS}
8 ${DBUS_INCLUDE_DIRS}
9)
10if (ENABLE_TRAY)
11 file(GLOB tray
12 tray/*.c
13 )
14endif()
15
16add_executable(swaybar
17 main.c
18 config.c
19 render.c
20 bar.c
21 status_line.c
22 ipc.c
23 event_loop.c
24 ${tray}
25)
26
27target_link_libraries(swaybar
28 sway-common
29 sway-wayland
30 ${WAYLAND_CLIENT_LIBRARIES}
31 ${WAYLAND_CURSOR_LIBRARIES}
32 ${CAIRO_LIBRARIES}
33 ${PANGO_LIBRARIES}
34 ${JSONC_LIBRARIES}
35 ${DBUS_LIBRARIES}
36)
37
38if (WITH_GDK_PIXBUF)
39 include_directories(
40 ${GDK_PIXBUF_INCLUDE_DIRS}
41 )
42endif()
43
44target_link_libraries(swaybar rt)
45
46install(
47 TARGETS swaybar
48 RUNTIME
49 DESTINATION bin
50 COMPONENT runtime
51)