summaryrefslogtreecommitdiffstats
path: root/sway/meson.build
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2018-04-12 20:19:54 -0400
committerLibravatar Drew DeVault <sir@cmpwn.com>2018-04-12 20:19:54 -0400
commitcd1b32453a9296c18b28bff71607aeb22987b5cd (patch)
treec653c6d525b471914c01a9d7ae543f521b6138ed /sway/meson.build
parentMerge pull request #1634 from aleksander/master (diff)
parentFix separator height calculation (diff)
downloadsway-cd1b32453a9296c18b28bff71607aeb22987b5cd.tar.gz
sway-cd1b32453a9296c18b28bff71607aeb22987b5cd.tar.zst
sway-cd1b32453a9296c18b28bff71607aeb22987b5cd.zip
Merge branch 'wlroots'
Diffstat (limited to 'sway/meson.build')
-rw-r--r--sway/meson.build131
1 files changed, 131 insertions, 0 deletions
diff --git a/sway/meson.build b/sway/meson.build
new file mode 100644
index 00000000..9e55e335
--- /dev/null
+++ b/sway/meson.build
@@ -0,0 +1,131 @@
1sway_sources = files(
2 'main.c',
3 'server.c',
4 'commands.c',
5 'config.c',
6 'criteria.c',
7 'debug-tree.c',
8 'ipc-json.c',
9 'ipc-server.c',
10 'security.c',
11
12 'desktop/desktop.c',
13 'desktop/output.c',
14 'desktop/layer_shell.c',
15 'desktop/wl_shell.c',
16 'desktop/xdg_shell_v6.c',
17 'desktop/xwayland.c',
18
19 'input/input-manager.c',
20 'input/seat.c',
21 'input/cursor.c',
22 'input/keyboard.c',
23
24 'config/bar.c',
25 'config/output.c',
26 'config/seat.c',
27 'config/input.c',
28
29 'commands/bar.c',
30 'commands/bind.c',
31 'commands/default_orientation.c',
32 'commands/exit.c',
33 'commands/exec.c',
34 'commands/exec_always.c',
35 'commands/focus.c',
36 'commands/focus_follows_mouse.c',
37 'commands/kill.c',
38 'commands/opacity.c',
39 'commands/include.c',
40 'commands/input.c',
41 'commands/layout.c',
42 'commands/mode.c',
43 'commands/mouse_warping.c',
44 'commands/move.c',
45 'commands/output.c',
46 'commands/reload.c',
47 'commands/resize.c',
48 'commands/seat.c',
49 'commands/seat/attach.c',
50 'commands/seat/cursor.c',
51 'commands/seat/fallback.c',
52 'commands/set.c',
53 'commands/split.c',
54 'commands/swaybg_command.c',
55 'commands/workspace.c',
56 'commands/ws_auto_back_and_forth.c',
57
58 'commands/bar/activate_button.c',
59 'commands/bar/binding_mode_indicator.c',
60 'commands/bar/bindsym.c',
61 'commands/bar/colors.c',
62 'commands/bar/context_button.c',
63 'commands/bar/font.c',
64 'commands/bar/height.c',
65 'commands/bar/hidden_state.c',
66 'commands/bar/icon_theme.c',
67 'commands/bar/id.c',
68 'commands/bar/mode.c',
69 'commands/bar/modifier.c',
70 'commands/bar/output.c',
71 'commands/bar/pango_markup.c',
72 'commands/bar/position.c',
73 'commands/bar/secondary_button.c',
74 'commands/bar/separator_symbol.c',
75 'commands/bar/status_command.c',
76 'commands/bar/strip_workspace_numbers.c',
77 'commands/bar/swaybar_command.c',
78 'commands/bar/tray_output.c',
79 'commands/bar/tray_padding.c',
80 'commands/bar/workspace_buttons.c',
81 'commands/bar/wrap_scroll.c',
82
83 'commands/input/accel_profile.c',
84 'commands/input/click_method.c',
85 'commands/input/drag_lock.c',
86 'commands/input/dwt.c',
87 'commands/input/events.c',
88 'commands/input/left_handed.c',
89 'commands/input/map_to_output.c',
90 'commands/input/middle_emulation.c',
91 'commands/input/natural_scroll.c',
92 'commands/input/pointer_accel.c',
93 'commands/input/scroll_method.c',
94 'commands/input/tap.c',
95 'commands/input/xkb_layout.c',
96 'commands/input/xkb_model.c',
97 'commands/input/xkb_options.c',
98 'commands/input/xkb_rules.c',
99 'commands/input/xkb_variant.c',
100
101 'tree/container.c',
102 'tree/layout.c',
103 'tree/view.c',
104 'tree/workspace.c',
105 'tree/output.c',
106)
107
108sway_deps = [
109 cairo,
110 gdk_pixbuf,
111 jsonc,
112 libcap,
113 libinput,
114 math,
115 pango,
116 pcre,
117 pixman,
118 server_protos,
119 wayland_server,
120 wlroots,
121 xkbcommon,
122]
123
124executable(
125 'sway',
126 sway_sources,
127 include_directories: [sway_inc],
128 dependencies: sway_deps,
129 link_with: [lib_sway_common],
130 install: true
131)