summaryrefslogtreecommitdiffstats
path: root/sway/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2016-01-28 08:39:51 -0500
committerLibravatar Mikkel Oscar Lyderik <mikkeloscar@gmail.com>2016-03-30 00:47:58 +0200
commit4611bba3dbf63a5ef67bf90d5ebd192eeb07742e (patch)
treea57320e5a6d463c020986c324a4671aaeed0e415 /sway/CMakeLists.txt
parentMerge pull request #553 from Hummer12007/master (diff)
downloadsway-4611bba3dbf63a5ef67bf90d5ebd192eeb07742e.tar.gz
sway-4611bba3dbf63a5ef67bf90d5ebd192eeb07742e.tar.zst
sway-4611bba3dbf63a5ef67bf90d5ebd192eeb07742e.zip
Initial setup of window border rendering
Please don't complain to me about the performance of this
Diffstat (limited to 'sway/CMakeLists.txt')
-rw-r--r--sway/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/sway/CMakeLists.txt b/sway/CMakeLists.txt
index 5b6104f3..6c62d676 100644
--- a/sway/CMakeLists.txt
+++ b/sway/CMakeLists.txt
@@ -5,6 +5,8 @@ include_directories(
5 ${JSONC_INCLUDE_DIRS} 5 ${JSONC_INCLUDE_DIRS}
6 ${XKBCOMMON_INCLUDE_DIRS} 6 ${XKBCOMMON_INCLUDE_DIRS}
7 ${LIBINPUT_INCLUDE_DIRS} 7 ${LIBINPUT_INCLUDE_DIRS}
8 ${CAIRO_INCLUDE_DIRS}
9 ${PANGO_INCLUDE_DIRS}
8) 10)
9 11
10add_executable(sway 12add_executable(sway
@@ -24,6 +26,7 @@ add_executable(sway
24 output.c 26 output.c
25 resize.c 27 resize.c
26 workspace.c 28 workspace.c
29 render.c
27) 30)
28 31
29add_definitions( 32add_definitions(
@@ -39,6 +42,8 @@ target_link_libraries(sway
39 ${JSONC_LIBRARIES} 42 ${JSONC_LIBRARIES}
40 ${WAYLAND_SERVER_LIBRARIES} 43 ${WAYLAND_SERVER_LIBRARIES}
41 ${LIBINPUT_LIBRARIES} 44 ${LIBINPUT_LIBRARIES}
45 ${PANGO_LIBRARIES}
46 ${JSONC_LIBRARIES}
42 m 47 m
43) 48)
44 49