summaryrefslogtreecommitdiffstats
path: root/sway/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Yacine Hmito <yacine.hmito@gmail.com>2016-01-21 21:04:52 +0100
committerLibravatar Yacine Hmito <yacine.hmito@gmail.com>2016-01-21 21:08:18 +0100
commitc487cf71a5cb5617053868a3db1f4a473ff99921 (patch)
tree4252d87c803f6be90a627cbcc60b0919481ed900 /sway/CMakeLists.txt
parentFix memory leak in config.c (diff)
downloadsway-c487cf71a5cb5617053868a3db1f4a473ff99921.tar.gz
sway-c487cf71a5cb5617053868a3db1f4a473ff99921.tar.zst
sway-c487cf71a5cb5617053868a3db1f4a473ff99921.zip
Fix issue #455
CMAKE_INSTALL_FULL_SYSCONFIG is not actually passed to the C preprocessor. I remember it working, so I must have messed up somewhere last time I touched this. This is fixed by manually passing its value to the C preprocessor through the SYSCONFDIR definition
Diffstat (limited to 'sway/CMakeLists.txt')
-rw-r--r--sway/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/sway/CMakeLists.txt b/sway/CMakeLists.txt
index f7cc88ab..d23c80b0 100644
--- a/sway/CMakeLists.txt
+++ b/sway/CMakeLists.txt
@@ -26,6 +26,10 @@ add_executable(sway
26 workspace.c 26 workspace.c
27) 27)
28 28
29add_definitions(
30 -DSYSCONFDIR="${CMAKE_INSTALL_FULL_SYSCONFDIR}"
31)
32
29target_link_libraries(sway 33target_link_libraries(sway
30 sway-common 34 sway-common
31 sway-protocols 35 sway-protocols