summaryrefslogtreecommitdiffstats
path: root/sway/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Greg V <greg@unrelenting.technology>2016-12-08 15:34:08 +0300
committerLibravatar Greg V <greg@unrelenting.technology>2016-12-09 19:32:07 +0300
commitda26d69cb1b21d582a81af0cad7342fab6596eed (patch)
tree18c24336e664111ba9c3a5bfedec5c340ec0a19d /sway/CMakeLists.txt
parentUse return value of write (diff)
downloadsway-da26d69cb1b21d582a81af0cad7342fab6596eed.tar.gz
sway-da26d69cb1b21d582a81af0cad7342fab6596eed.tar.zst
sway-da26d69cb1b21d582a81af0cad7342fab6596eed.zip
Fix build on FreeBSD
- Make sure CMake always finds absolute paths for Cairo, Pango and GdkPixbuf - Add forgotten json-c include path to swaymsg/CMakeLists.txt - Disable -Werror because of assert warnings - Add correct /proc/pid/file path for FreeBSD - Use libepoll-shim on FreeBSD - Only use Linux capabilities on, well, Linux
Diffstat (limited to 'sway/CMakeLists.txt')
-rw-r--r--sway/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/sway/CMakeLists.txt b/sway/CMakeLists.txt
index d1afadb6..4532a6c3 100644
--- a/sway/CMakeLists.txt
+++ b/sway/CMakeLists.txt
@@ -55,9 +55,12 @@ target_link_libraries(sway
55 ${PANGO_LIBRARIES} 55 ${PANGO_LIBRARIES}
56 ${JSONC_LIBRARIES} 56 ${JSONC_LIBRARIES}
57 m 57 m
58 cap
59) 58)
60 59
60if (CMAKE_SYSTEM_NAME STREQUAL Linux)
61 target_link_libraries(sway cap)
62endif (CMAKE_SYSTEM_NAME STREQUAL Linux)
63
61install( 64install(
62 TARGETS sway 65 TARGETS sway
63 RUNTIME 66 RUNTIME