summaryrefslogtreecommitdiffstats
path: root/sway/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Zandr Martin <zandrmartin@gmail.com>2016-09-01 21:39:08 -0500
committerLibravatar Zandr Martin <zandrmartin@gmail.com>2016-09-01 21:39:08 -0500
commitb374c35758777f98e5ddbe4b0dc43bd7c80f36d7 (patch)
tree04bb4cfc3da7d2e0de7fbc38db42f65c66d2df4c /sway/CMakeLists.txt
parentMerge pull request #874 from yohanesu75/ipc-client-fix (diff)
downloadsway-b374c35758777f98e5ddbe4b0dc43bd7c80f36d7.tar.gz
sway-b374c35758777f98e5ddbe4b0dc43bd7c80f36d7.tar.zst
sway-b374c35758777f98e5ddbe4b0dc43bd7c80f36d7.zip
refactor commands.c
Diffstat (limited to 'sway/CMakeLists.txt')
-rw-r--r--sway/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/sway/CMakeLists.txt b/sway/CMakeLists.txt
index be63c944..36c03923 100644
--- a/sway/CMakeLists.txt
+++ b/sway/CMakeLists.txt
@@ -10,8 +10,15 @@ include_directories(
10 ${WAYLAND_INCLUDE_DIR} 10 ${WAYLAND_INCLUDE_DIR}
11) 11)
12 12
13file(GLOB cmds
14 "commands/*.c"
15 "commands/bar/*.c"
16 "commands/input/*.c"
17)
18
13add_executable(sway 19add_executable(sway
14 commands.c 20 commands.c
21 ${cmds}
15 config.c 22 config.c
16 container.c 23 container.c
17 criteria.c 24 criteria.c