summaryrefslogtreecommitdiffstats
path: root/sway/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Cole Mickens <cole.mickens@gmail.com>2016-01-17 02:53:37 -0800
committerLibravatar Cole Mickens <cole.mickens@gmail.com>2016-01-19 06:51:36 -0800
commit28081b76891ddbbb825dee6c202037d78aa8f164 (patch)
tree6b7412f626f5d9f10dba8920a2543dfd3c5a662e /sway/CMakeLists.txt
parentAdd ffmpeg/imagemagick to depenency list (diff)
downloadsway-28081b76891ddbbb825dee6c202037d78aa8f164.tar.gz
sway-28081b76891ddbbb825dee6c202037d78aa8f164.tar.zst
sway-28081b76891ddbbb825dee6c202037d78aa8f164.zip
libinput
Diffstat (limited to 'sway/CMakeLists.txt')
-rw-r--r--sway/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/sway/CMakeLists.txt b/sway/CMakeLists.txt
index 23829dc3..f7cc88ab 100644
--- a/sway/CMakeLists.txt
+++ b/sway/CMakeLists.txt
@@ -4,6 +4,7 @@ include_directories(
4 ${PCRE_INCLUDE_DIRS} 4 ${PCRE_INCLUDE_DIRS}
5 ${JSONC_INCLUDE_DIRS} 5 ${JSONC_INCLUDE_DIRS}
6 ${XKBCOMMON_INCLUDE_DIRS} 6 ${XKBCOMMON_INCLUDE_DIRS}
7 ${LIBINPUT_LIBRARIES}
7) 8)
8 9
9add_executable(sway 10add_executable(sway
@@ -15,6 +16,7 @@ add_executable(sway
15 extensions.c 16 extensions.c
16 focus.c 17 focus.c
17 handlers.c 18 handlers.c
19 input.c
18 input_state.c 20 input_state.c
19 ipc-server.c 21 ipc-server.c
20 layout.c 22 layout.c
@@ -32,6 +34,7 @@ target_link_libraries(sway
32 ${PCRE_LIBRARIES} 34 ${PCRE_LIBRARIES}
33 ${JSONC_LIBRARIES} 35 ${JSONC_LIBRARIES}
34 ${WAYLAND_SERVER_LIBRARIES} 36 ${WAYLAND_SERVER_LIBRARIES}
37 ${LIBINPUT_LIBRARIES}
35 m 38 m
36) 39)
37 40