aboutsummaryrefslogtreecommitdiffstats
path: root/protocols/meson.build
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2018-03-28 15:25:33 -0400
committerLibravatar GitHub <noreply@github.com>2018-03-28 15:25:33 -0400
commit9070950eecded7bfa64e7bca3bb76b150ccc8b72 (patch)
tree509a9c669bf2679085e27a1ff1b0c95526abf14c /protocols/meson.build
parentMerge pull request #1641 from swaywm/transformed-events (diff)
parentAddress review comments (diff)
downloadsway-9070950eecded7bfa64e7bca3bb76b150ccc8b72.tar.gz
sway-9070950eecded7bfa64e7bca3bb76b150ccc8b72.tar.zst
sway-9070950eecded7bfa64e7bca3bb76b150ccc8b72.zip
Merge pull request #1638 from swaywm/swaybg-layers
Reimplement swaybg using surface layers
Diffstat (limited to 'protocols/meson.build')
-rw-r--r--protocols/meson.build37
1 files changed, 37 insertions, 0 deletions
diff --git a/protocols/meson.build b/protocols/meson.build
new file mode 100644
index 00000000..1fda600e
--- /dev/null
+++ b/protocols/meson.build
@@ -0,0 +1,37 @@
1wl_protocol_dir = wayland_protos.get_pkgconfig_variable('pkgdatadir')
2
3wayland_scanner = find_program('wayland-scanner')
4
5wayland_scanner_code = generator(
6 wayland_scanner,
7 output: '@BASENAME@-protocol.c',
8 arguments: ['code', '@INPUT@', '@OUTPUT@'],
9)
10
11wayland_scanner_client = generator(
12 wayland_scanner,
13 output: '@BASENAME@-client-protocol.h',
14 arguments: ['client-header', '@INPUT@', '@OUTPUT@'],
15)
16
17protocols = [
18 [wl_protocol_dir, 'stable/xdg-shell/xdg-shell.xml'],
19 ['wlr-layer-shell-unstable-v1.xml']
20]
21
22wl_protos_src = []
23wl_protos_headers = []
24
25foreach p : protocols
26 xml = join_paths(p)
27 wl_protos_src += wayland_scanner_code.process(xml)
28 wl_protos_headers += wayland_scanner_client.process(xml)
29endforeach
30
31lib_wl_protos = static_library('wl_protos', wl_protos_src + wl_protos_headers,
32 dependencies: [wayland_client]) # for the include directory
33
34sway_protos = declare_dependency(
35 link_with: lib_wl_protos,
36 sources: wl_protos_headers,
37)