summaryrefslogtreecommitdiffstats
path: root/protocols/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2015-12-02 05:34:18 -0500
committerLibravatar Drew DeVault <sir@cmpwn.com>2015-12-02 05:34:18 -0500
commit7a1c8c2939c8581bb47323513b91a94aebf62b36 (patch)
tree717052d8d88f3fd14d26566daa520dbdd3a452fe /protocols/CMakeLists.txt
parentMerge pull request #290 from christophgysin/cmake (diff)
parentcmake: build common code only once (diff)
downloadsway-7a1c8c2939c8581bb47323513b91a94aebf62b36.tar.gz
sway-7a1c8c2939c8581bb47323513b91a94aebf62b36.tar.zst
sway-7a1c8c2939c8581bb47323513b91a94aebf62b36.zip
Merge pull request #291 from christophgysin/libs
cmake: build common code only once
Diffstat (limited to 'protocols/CMakeLists.txt')
-rw-r--r--protocols/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/protocols/CMakeLists.txt b/protocols/CMakeLists.txt
new file mode 100644
index 00000000..07becc36
--- /dev/null
+++ b/protocols/CMakeLists.txt
@@ -0,0 +1,22 @@
1include(Wayland)
2
3WAYLAND_ADD_PROTOCOL_CLIENT(proto-client-xdg-shell
4 xdg-shell.xml
5 xdg-shell
6)
7WAYLAND_ADD_PROTOCOL_CLIENT(proto-client-desktop-shell
8 desktop-shell.xml
9 desktop-shell
10)
11WAYLAND_ADD_PROTOCOL_SERVER(proto-server-desktop-shell
12 desktop-shell.xml
13 desktop-shell
14)
15
16add_library(sway-protocols
17 ${proto-client-xdg-shell}
18 ${proto-client-desktop-shell}
19 ${proto-server-desktop-shell}
20 )
21
22set(PROTOCOLS_INCLUDE_DIRS ${CMAKE_BINARY_DIR}/protocols PARENT_SCOPE)