aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar Tony Crisci <tony@dubstepdish.com>2017-11-30 11:51:58 -0500
committerLibravatar Tony Crisci <tony@dubstepdish.com>2017-11-30 11:51:58 -0500
commitfe5c0316096b47d9a9bbede1d35e52e04ad9b40f (patch)
treed6a6c55fc4769a7d69816e0e2950cc2808bf11a6 /meson.build
parentmeson build swaymsg (diff)
downloadsway-fe5c0316096b47d9a9bbede1d35e52e04ad9b40f.tar.gz
sway-fe5c0316096b47d9a9bbede1d35e52e04ad9b40f.tar.zst
sway-fe5c0316096b47d9a9bbede1d35e52e04ad9b40f.zip
meson zsh completions install
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1c322131..05d92a91 100644
--- a/meson.build
+++ b/meson.build
@@ -131,3 +131,15 @@ if (get_option('default_wallpaper'))
131 131
132 install_data(wallpaper_files, install_dir: wallpaper_install_dir) 132 install_data(wallpaper_files, install_dir: wallpaper_install_dir)
133endif 133endif
134
135if (get_option('zsh_completions'))
136 zsh_files = files(
137 'completions/zsh/_sway',
138 'completions/zsh/_swaygrab',
139 'completions/zsh/_swaylock',
140 'completions/zsh/_swaymsg',
141 )
142 zsh_install_dir = datadir + '/zsh/site-functions'
143
144 install_data(zsh_files, install_dir: zsh_install_dir)
145endif