aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar emersion <contact@emersion.fr>2019-02-27 22:19:53 +0100
committerLibravatar Brian Ashworth <bosrsf04@gmail.com>2019-03-01 10:25:47 -0500
commitf98410c090c995d491ba538850b792c763407583 (patch)
treec5ee0aeebe32ab046e3176c97fc9b2a542d20510 /meson.build
parentseat: don't send button release when not pressed (diff)
downloadsway-f98410c090c995d491ba538850b792c763407583.tar.gz
sway-f98410c090c995d491ba538850b792c763407583.tar.zst
sway-f98410c090c995d491ba538850b792c763407583.zip
meson: check scdoc version
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 53454cdd..270dc6b7 100644
--- a/meson.build
+++ b/meson.build
@@ -95,8 +95,9 @@ conf_data.set10('HAVE_SYSTEMD', systemd.found())
95conf_data.set10('HAVE_ELOGIND', elogind.found()) 95conf_data.set10('HAVE_ELOGIND', elogind.found())
96conf_data.set10('HAVE_TRAY', have_tray) 96conf_data.set10('HAVE_TRAY', have_tray)
97 97
98scdoc = find_program('scdoc', required: get_option('man-pages')) 98scdoc = dependency('scdoc', version: '>=1.9', native: true, required: get_option('man-pages'))
99if scdoc.found() 99if scdoc.found()
100 scdoc_prog = find_program('scdoc')
100 sh = find_program('sh') 101 sh = find_program('sh')
101 mandir = get_option('mandir') 102 mandir = get_option('mandir')
102 man_files = [ 103 man_files = [
@@ -120,7 +121,7 @@ if scdoc.found()
120 input: filename, 121 input: filename,
121 output: output, 122 output: output,
122 command: [ 123 command: [
123 sh, '-c', '@0@ < @INPUT@ > @1@'.format(scdoc.path(), output) 124 sh, '-c', '@0@ < @INPUT@ > @1@'.format(scdoc_prog.path(), output)
124 ], 125 ],
125 install: true, 126 install: true,
126 install_dir: '@0@/man@1@'.format(mandir, section) 127 install_dir: '@0@/man@1@'.format(mandir, section)