aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar Tadeo Kondrak <me@tadeo.ca>2021-02-23 11:47:38 -0700
committerLibravatar Simon Ser <contact@emersion.fr>2021-02-23 20:27:38 +0100
commitde471e67d3cb4ec788cbf060dff48ad262cd315f (patch)
treee3a971013e457df16f72eb616c3130f3bb99d5f4 /meson.build
parentshells: Update comment about size change on commit (diff)
downloadsway-de471e67d3cb4ec788cbf060dff48ad262cd315f.tar.gz
sway-de471e67d3cb4ec788cbf060dff48ad262cd315f.tar.zst
sway-de471e67d3cb4ec788cbf060dff48ad262cd315f.zip
build: Add dependency on libdrm
As of 66343839b146a54505b746784cd42a8efb844963, sway now uses a libdrm header. Add this dependency to the build system so headers from it can be used on systems where pkg-config is required to find them.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9177ca33..19cb5130 100644
--- a/meson.build
+++ b/meson.build
@@ -52,6 +52,8 @@ glesv2 = dependency('glesv2')
52libevdev = dependency('libevdev') 52libevdev = dependency('libevdev')
53libinput = dependency('libinput', version: '>=1.6.0') 53libinput = dependency('libinput', version: '>=1.6.0')
54xcb = dependency('xcb', required: get_option('xwayland')) 54xcb = dependency('xcb', required: get_option('xwayland'))
55drm_full = dependency('libdrm') # only needed for drm_fourcc.h
56drm = drm_full.partial_dependency(compile_args: true, includes: true)
55bash_comp = dependency('bash-completion', required: false) 57bash_comp = dependency('bash-completion', required: false)
56fish_comp = dependency('fish', required: false) 58fish_comp = dependency('fish', required: false)
57math = cc.find_library('m') 59math = cc.find_library('m')