aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar Kirill Chibisov <contact@kchibisov.com>2022-01-10 17:54:24 +0300
committerLibravatar Simon Ser <contact@emersion.fr>2022-01-12 17:25:34 +0100
commitdbaf2e4fdb327f05f792b69430fe6f893fc9d879 (patch)
tree8e48fdd24e0c8f7b172f0184419ae5eb41ce7421 /meson.build
parentxdg-shell: use toplevel geometry to adjust the popup box (diff)
downloadsway-dbaf2e4fdb327f05f792b69430fe6f893fc9d879.tar.gz
sway-dbaf2e4fdb327f05f792b69430fe6f893fc9d879.tar.zst
sway-dbaf2e4fdb327f05f792b69430fe6f893fc9d879.zip
build: fix building with basu
02b412a introduced the use of list for sdbus deps, however it was assuming that all packages which were in a list has a version higher than 239. That is true for libsystemd and libelogind, since they use the same versions, however basu is using version numbers which are way lower than what libsystemd/libelogind are using, so basu only build is failing.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 10 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 0182b8f0..b226ac83 100644
--- a/meson.build
+++ b/meson.build
@@ -92,15 +92,22 @@ if get_option('sd-bus-provider') == 'auto'
92 if not get_option('tray').disabled() 92 if not get_option('tray').disabled()
93 assert(get_option('auto_features').auto(), 'sd-bus-provider must not be set to auto since auto_features != auto') 93 assert(get_option('auto_features').auto(), 'sd-bus-provider must not be set to auto since auto_features != auto')
94 endif 94 endif
95 sdbus = dependency(['libsystemd', 'libelogind', 'basu'], 95 sdbus = dependency(['libsystemd', 'libelogind'],
96 required: get_option('tray'), 96 required: false,
97 version: '>=239', 97 version: '>=239',
98 ) 98 )
99 if not sdbus.found()
100 sdbus = dependency('basu', required: false)
101 endif
99else 102else
100 sdbus = dependency(get_option('sd-bus-provider'), required: get_option('tray')) 103 sdbus = dependency(get_option('sd-bus-provider'), required: get_option('tray'))
101endif 104endif
102 105
103have_tray = sdbus.found() 106tray_deps_found = sdbus.found()
107if get_option('tray').enabled() and not tray_deps_found
108 error('Building with -Dtray=enabled, but sd-bus has not been not found')
109endif
110have_tray = (not get_option('tray').disabled()) and tray_deps_found
104 111
105conf_data = configuration_data() 112conf_data = configuration_data()
106 113