aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar Eric Engestrom <eric.engestrom@intel.com>2018-07-27 17:50:33 +0100
committerLibravatar Eric Engestrom <eric.engestrom@intel.com>2018-07-30 15:56:50 +0100
commitb9d531b3181a0877ea3b94d5f9aa5877bbddeb1b (patch)
tree0dd521bdaa228843b36f1c532a42f0bc3540d41f /meson.build
parentbash: add completion for swayidle (diff)
downloadsway-b9d531b3181a0877ea3b94d5f9aa5877bbddeb1b.tar.gz
sway-b9d531b3181a0877ea3b94d5f9aa5877bbddeb1b.tar.zst
sway-b9d531b3181a0877ea3b94d5f9aa5877bbddeb1b.zip
meson: install bash completion
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1cb40ade..5be1f8d2 100644
--- a/meson.build
+++ b/meson.build
@@ -191,3 +191,15 @@ if (get_option('zsh_completions'))
191 191
192 install_data(zsh_files, install_dir: zsh_install_dir) 192 install_data(zsh_files, install_dir: zsh_install_dir)
193endif 193endif
194
195if (get_option('bash_completions'))
196 bash_files = files(
197 'completions/bash/sway',
198 'completions/bash/swayidle',
199 'completions/bash/swaylock',
200 'completions/bash/swaymsg',
201 )
202 bash_install_dir = datadir + '/bash-completion/completions'
203
204 install_data(bash_files, install_dir: bash_install_dir)
205endif