aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar emersion <contact@emersion.fr>2019-02-27 21:13:16 +0100
committerLibravatar emersion <contact@emersion.fr>2019-02-27 21:13:16 +0100
commit8228fa60d4e03b4b9f541cdc411d28c106cef2d3 (patch)
tree0e02145fe711927ac52788f0e3d939be6c81089d /meson.build
parentconfig: remove double assignement to result in get_output_config (diff)
downloadsway-8228fa60d4e03b4b9f541cdc411d28c106cef2d3.tar.gz
sway-8228fa60d4e03b4b9f541cdc411d28c106cef2d3.tar.zst
sway-8228fa60d4e03b4b9f541cdc411d28c106cef2d3.zip
Set minimum wlroots version
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index d3172bdd..aaffc41f 100644
--- a/meson.build
+++ b/meson.build
@@ -60,17 +60,19 @@ rt = cc.find_library('rt')
60git = find_program('git', required: false) 60git = find_program('git', required: false)
61 61
62# Try first to find wlroots as a subproject, then as a system dependency 62# Try first to find wlroots as a subproject, then as a system dependency
63wlroots_version = '>=0.4.1'
63wlroots_proj = subproject( 64wlroots_proj = subproject(
64 'wlroots', 65 'wlroots',
65 default_options: ['rootston=false', 'examples=false'], 66 default_options: ['rootston=false', 'examples=false'],
66 required: false, 67 required: false,
68 version: wlroots_version,
67) 69)
68if wlroots_proj.found() 70if wlroots_proj.found()
69 wlroots = wlroots_proj.get_variable('wlroots') 71 wlroots = wlroots_proj.get_variable('wlroots')
70 wlroots_conf = wlroots_proj.get_variable('conf_data') 72 wlroots_conf = wlroots_proj.get_variable('conf_data')
71 wlroots_has_xwayland = wlroots_conf.get('WLR_HAS_XWAYLAND') == 1 73 wlroots_has_xwayland = wlroots_conf.get('WLR_HAS_XWAYLAND') == 1
72else 74else
73 wlroots = dependency('wlroots') 75 wlroots = dependency('wlroots', version: wlroots_version)
74 wlroots_has_xwayland = cc.get_define('WLR_HAS_XWAYLAND', prefix: '#include <wlr/config.h>', dependencies: wlroots) == '1' 76 wlroots_has_xwayland = cc.get_define('WLR_HAS_XWAYLAND', prefix: '#include <wlr/config.h>', dependencies: wlroots) == '1'
75endif 77endif
76 78