aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar Dominique Martinet <asmadeus@codewreck.org>2020-03-29 10:06:48 +0200
committerLibravatar Simon Ser <contact@emersion.fr>2020-04-04 17:55:09 +0200
commit4e82d0fb15b108eb44bc8a4cb92b2d9a8af1232e (patch)
treef1172b89000d3711992bb4bb7847e318ee34fc9a /meson.build
parentim: Fix crash when im destorying and no focused surface exists (diff)
downloadsway-4e82d0fb15b108eb44bc8a4cb92b2d9a8af1232e.tar.gz
sway-4e82d0fb15b108eb44bc8a4cb92b2d9a8af1232e.tar.zst
sway-4e82d0fb15b108eb44bc8a4cb92b2d9a8af1232e.zip
build: make completions respect install prefixes
Tell pkgconfig about prefix and datadir as required in the .pc files, so if the prefix isn't standard nothing is installed outside of it. For fish, this requires https://github.com/fish-shell/fish-shell/pull/6778 Fixes swaywm/swaybg#13
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 8 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index bb3e4f49..fbd9752a 100644
--- a/meson.build
+++ b/meson.build
@@ -263,7 +263,10 @@ if get_option('bash-completions')
263 'completions/bash/swaymsg', 263 'completions/bash/swaymsg',
264 ) 264 )
265 if bash_comp.found() 265 if bash_comp.found()
266 bash_install_dir = bash_comp.get_pkgconfig_variable('completionsdir') 266 bash_install_dir = bash_comp.get_pkgconfig_variable(
267 'completionsdir',
268 define_variable: ['datadir', datadir]
269 )
267 else 270 else
268 bash_install_dir = join_paths(datadir, 'bash-completion', 'completions') 271 bash_install_dir = join_paths(datadir, 'bash-completion', 'completions')
269 endif 272 endif
@@ -278,7 +281,10 @@ if get_option('fish-completions')
278 'completions/fish/swaynag.fish', 281 'completions/fish/swaynag.fish',
279 ) 282 )
280 if fish_comp.found() 283 if fish_comp.found()
281 fish_install_dir = fish_comp.get_pkgconfig_variable('completionsdir') 284 fish_install_dir = fish_comp.get_pkgconfig_variable(
285 'completionsdir',
286 define_variable: ['datadir', datadir]
287 )
282 else 288 else
283 fish_install_dir = join_paths(datadir, 'fish', 'vendor_completions.d') 289 fish_install_dir = join_paths(datadir, 'fish', 'vendor_completions.d')
284 endif 290 endif