aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar Eli Schwartz <eschwartz@archlinux.org>2020-01-21 23:05:43 -0500
committerLibravatar Simon Ser <contact@emersion.fr>2020-01-22 18:05:29 +0100
commit4a73f69d104d037c0aa3873a0cd1536587080eee (patch)
tree5a73bef86c0508b167cfc2ce4fd31d94d72a0161 /meson.build
parentcompletion: use pkg-config to get install location for bash/fish (diff)
downloadsway-4a73f69d104d037c0aa3873a0cd1536587080eee.tar.gz
sway-4a73f69d104d037c0aa3873a0cd1536587080eee.tar.zst
sway-4a73f69d104d037c0aa3873a0cd1536587080eee.zip
fish-completion: use the correct fallback directory
fish completions should never be installed to share/fish/completions/ as that directory is reserved exclusively for completions shipped as part of the fish source code. Use the same vendor_completions.d/ directory which the default fish configuration uses.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index ca0c791f..54351812 100644
--- a/meson.build
+++ b/meson.build
@@ -280,7 +280,7 @@ if get_option('fish-completions')
280 if fish_comp.found() 280 if fish_comp.found()
281 fish_install_dir = fish_comp.get_pkgconfig_variable('completionsdir') 281 fish_install_dir = fish_comp.get_pkgconfig_variable('completionsdir')
282 else 282 else
283 fish_install_dir = join_paths(datadir, 'fish', 'completions') 283 fish_install_dir = join_paths(datadir, 'fish', 'vendor_completions.d')
284 endif 284 endif
285 285
286 install_data(fish_files, install_dir: fish_install_dir) 286 install_data(fish_files, install_dir: fish_install_dir)