aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar Kenny Levinsen <kl@kl.wtf>2022-01-11 11:35:44 +0100
committerLibravatar Simon Ser <contact@emersion.fr>2022-01-11 11:51:49 +0100
commit470e04e8da6e078da77190998b5e0c34e244839a (patch)
tree1cffb9e02576da59552acb7f8166613be4b989f5 /meson.build
parentAdd safety assert in parse_movement_unit (diff)
downloadsway-470e04e8da6e078da77190998b5e0c34e244839a.tar.gz
sway-470e04e8da6e078da77190998b5e0c34e244839a.tar.zst
sway-470e04e8da6e078da77190998b5e0c34e244839a.zip
meson: check: false on run_command
Future meson releases will change the default and warns when the implicit default is used, breaking builds. Explicitly set check: false to maintain behavior and silence warnings.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 4da9403b..0182b8f0 100644
--- a/meson.build
+++ b/meson.build
@@ -156,8 +156,8 @@ add_project_arguments('-DSYSCONFDIR="/@0@"'.format(join_paths(prefix, sysconfdir
156version = '"@0@"'.format(meson.project_version()) 156version = '"@0@"'.format(meson.project_version())
157git = find_program('git', native: true, required: false) 157git = find_program('git', native: true, required: false)
158if git.found() 158if git.found()
159 git_commit = run_command([git, 'rev-parse', '--short', 'HEAD']) 159 git_commit = run_command([git, 'rev-parse', '--short', 'HEAD'], check: false)
160 git_branch = run_command([git, 'rev-parse', '--abbrev-ref', 'HEAD']) 160 git_branch = run_command([git, 'rev-parse', '--abbrev-ref', 'HEAD'], check: false)
161 if git_commit.returncode() == 0 and git_branch.returncode() == 0 161 if git_commit.returncode() == 0 and git_branch.returncode() == 0
162 version = '"@0@-@1@ (" __DATE__ ", branch \'@2@\')"'.format( 162 version = '"@0@-@1@ (" __DATE__ ", branch \'@2@\')"'.format(
163 meson.project_version(), 163 meson.project_version(),