aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar Simon Ser <contact@emersion.fr>2021-02-23 20:32:11 +0100
committerLibravatar Simon Ser <contact@emersion.fr>2021-02-23 20:32:11 +0100
commit307b26a14949b477a5fd30cf6073f4dca304e81d (patch)
treefd56fe5a949847053be95c408b3aa2c1ca2c3117 /meson.build
parentbuild: Add dependency on libdrm (diff)
downloadsway-307b26a14949b477a5fd30cf6073f4dca304e81d.tar.gz
sway-307b26a14949b477a5fd30cf6073f4dca304e81d.tar.zst
sway-307b26a14949b477a5fd30cf6073f4dca304e81d.zip
build: stop cargo-culting assignment alignment
The Sway style guide says we shouldn't align assignments.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build38
1 files changed, 19 insertions, 19 deletions
diff --git a/meson.build b/meson.build
index 19cb5130..cb4ee20e 100644
--- a/meson.build
+++ b/meson.build
@@ -35,29 +35,29 @@ if is_freebsd
35 add_project_arguments('-D_C11_SOURCE', language: 'c') 35 add_project_arguments('-D_C11_SOURCE', language: 'c')
36endif 36endif
37 37
38jsonc = dependency('json-c', version: '>=0.13') 38jsonc = dependency('json-c', version: '>=0.13')
39pcre = dependency('libpcre') 39pcre = dependency('libpcre')
40wayland_server = dependency('wayland-server') 40wayland_server = dependency('wayland-server')
41wayland_client = dependency('wayland-client') 41wayland_client = dependency('wayland-client')
42wayland_cursor = dependency('wayland-cursor') 42wayland_cursor = dependency('wayland-cursor')
43wayland_egl = dependency('wayland-egl') 43wayland_egl = dependency('wayland-egl')
44wayland_protos = dependency('wayland-protocols', version: '>=1.14') 44wayland_protos = dependency('wayland-protocols', version: '>=1.14')
45xkbcommon = dependency('xkbcommon') 45xkbcommon = dependency('xkbcommon')
46cairo = dependency('cairo') 46cairo = dependency('cairo')
47pango = dependency('pango') 47pango = dependency('pango')
48pangocairo = dependency('pangocairo') 48pangocairo = dependency('pangocairo')
49gdk_pixbuf = dependency('gdk-pixbuf-2.0', required: get_option('gdk-pixbuf')) 49gdk_pixbuf = dependency('gdk-pixbuf-2.0', required: get_option('gdk-pixbuf'))
50pixman = dependency('pixman-1') 50pixman = dependency('pixman-1')
51glesv2 = dependency('glesv2') 51glesv2 = dependency('glesv2')
52libevdev = dependency('libevdev') 52libevdev = dependency('libevdev')
53libinput = dependency('libinput', version: '>=1.6.0') 53libinput = dependency('libinput', version: '>=1.6.0')
54xcb = dependency('xcb', required: get_option('xwayland')) 54xcb = dependency('xcb', required: get_option('xwayland'))
55drm_full = dependency('libdrm') # only needed for drm_fourcc.h 55drm_full = dependency('libdrm') # only needed for drm_fourcc.h
56drm = drm_full.partial_dependency(compile_args: true, includes: true) 56drm = drm_full.partial_dependency(compile_args: true, includes: true)
57bash_comp = dependency('bash-completion', required: false) 57bash_comp = dependency('bash-completion', required: false)
58fish_comp = dependency('fish', required: false) 58fish_comp = dependency('fish', required: false)
59math = cc.find_library('m') 59math = cc.find_library('m')
60rt = cc.find_library('rt') 60rt = cc.find_library('rt')
61 61
62# Try first to find wlroots as a subproject, then as a system dependency 62# Try first to find wlroots as a subproject, then as a system dependency
63wlroots_version = ['>=0.12.0', '<0.13.0'] 63wlroots_version = ['>=0.12.0', '<0.13.0']