aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2018-03-28 12:21:50 -0400
committerLibravatar Drew DeVault <sir@cmpwn.com>2018-03-28 14:43:23 -0400
commitd39bda76c4007c42452a81883fefc671b816a74b (patch)
tree509a9c669bf2679085e27a1ff1b0c95526abf14c /meson.build
parentRefactor configure/ack configure/commit flow (diff)
downloadsway-d39bda76c4007c42452a81883fefc671b816a74b.tar.gz
sway-d39bda76c4007c42452a81883fefc671b816a74b.tar.zst
sway-d39bda76c4007c42452a81883fefc671b816a74b.zip
Address review comments
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 0c35b0e5..b681f43a 100644
--- a/meson.build
+++ b/meson.build
@@ -38,8 +38,10 @@ math = cc.find_library('m')
38git = find_program('git', required: false) 38git = find_program('git', required: false)
39a2x = find_program('a2x', required: false) 39a2x = find_program('a2x', required: false)
40 40
41conf_data = configuration_data()
42
41if gdk_pixbuf.found() 43if gdk_pixbuf.found()
42 add_project_arguments('-DWITH_GDK_PIXBUF', language : 'c') 44 conf_data.set('HAVE_GDK_PIXBUF', true)
43endif 45endif
44 46
45if a2x.found() 47if a2x.found()
@@ -92,6 +94,7 @@ add_project_arguments('-DSWAY_VERSION=@0@'.format(version), language: 'c')
92 94
93sway_inc = include_directories('include') 95sway_inc = include_directories('include')
94 96
97subdir('include')
95subdir('protocols') 98subdir('protocols')
96subdir('common') 99subdir('common')
97subdir('sway') 100subdir('sway')