aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar sghctoma <sghctoma@gmail.com>2018-08-30 09:44:24 +0200
committerLibravatar sghctoma <sghctoma@gmail.com>2018-08-30 09:44:24 +0200
commit6942f5b6845b2cc572ec378365771a34caf50ba1 (patch)
treeea05939746befa66cf7676a8362e91fff98e694d /meson.build
parentMake libcap an optional dependency (diff)
downloadsway-6942f5b6845b2cc572ec378365771a34caf50ba1.tar.gz
sway-6942f5b6845b2cc572ec378365771a34caf50ba1.tar.zst
sway-6942f5b6845b2cc572ec378365771a34caf50ba1.zip
Fix SYSCONFDIR to include "prefix"
SYSCONFDIR is used to determine the path of the default configuration file. 'sysconfdir' is set to 'prefix/sysconfdir' later (on line 139), so configuration files are installed under 'prefix', but SYSCONFDIR did not reflect it.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 61fcff42..57b024c8 100644
--- a/meson.build
+++ b/meson.build
@@ -104,7 +104,7 @@ if scdoc.found()
104 endforeach 104 endforeach
105endif 105endif
106 106
107add_project_arguments('-DSYSCONFDIR="/@0@"'.format(sysconfdir), language : 'c') 107add_project_arguments('-DSYSCONFDIR="/@0@/@1@"'.format(prefix, sysconfdir), language : 'c')
108 108
109version = get_option('sway_version') 109version = get_option('sway_version')
110if version != '' 110if version != ''