aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLibravatar emersion <contact@emersion.fr>2018-09-30 15:04:13 +0200
committerLibravatar GitHub <noreply@github.com>2018-09-30 15:04:13 +0200
commitbebe7dea8cd5ee4e10a368551c595397008e2d51 (patch)
tree63e09dad69399fe4470830b3103301a97ce0ab7f /meson.build
parentMerge pull request #2726 from RyanDwyer/overhaul-gaps (diff)
parentAdd support for installing binaries with DT_RPATH (diff)
downloadsway-bebe7dea8cd5ee4e10a368551c595397008e2d51.tar.gz
sway-bebe7dea8cd5ee4e10a368551c595397008e2d51.tar.zst
sway-bebe7dea8cd5ee4e10a368551c595397008e2d51.zip
Merge pull request #2734 from ivyl/use_rpath
Add support for installing binaries with DT_RPATH
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 10 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 080709fa..1e7ce281 100644
--- a/meson.build
+++ b/meson.build
@@ -128,7 +128,16 @@ else
128endif 128endif
129add_project_arguments('-DSWAY_VERSION=@0@'.format(version), language: 'c') 129add_project_arguments('-DSWAY_VERSION=@0@'.format(version), language: 'c')
130 130
131add_project_arguments('-D_LD_LIBRARY_PATH="@0@"'.format(get_option('ld-library-path')), language: 'c') 131if get_option('use_rpath')
132 if get_option('custom_rpath') == ''
133 # default to platform specific libdir, one level up from the binary
134 rpathdir = join_paths('$ORIGIN', '..', '$LIB')
135 else
136 rpathdir = get_option('custom_rpath')
137 endif
138else
139 rpathdir = ''
140endif
132 141
133sway_inc = include_directories('include') 142sway_inc = include_directories('include')
134 143