aboutsummaryrefslogtreecommitdiffstats
path: root/common/meson.build
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2018-04-02 21:57:13 -0400
committerLibravatar Drew DeVault <sir@cmpwn.com>2018-04-04 18:47:48 -0400
commita28730edee1896242012f80fd0e63e7966652e02 (patch)
treee85d2479ce1b77e23b3c3e34c1d9e0bf87ed30f0 /common/meson.build
parentMerge pull request #1731 from acrisci/ipc-window-events (diff)
downloadsway-a28730edee1896242012f80fd0e63e7966652e02.tar.gz
sway-a28730edee1896242012f80fd0e63e7966652e02.tar.zst
sway-a28730edee1896242012f80fd0e63e7966652e02.zip
Move swaybg background rendering into common/
swaylock will use it too
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build20
1 files changed, 8 insertions, 12 deletions
diff --git a/common/meson.build b/common/meson.build
index 4ad47077..851e7bbf 100644
--- a/common/meson.build
+++ b/common/meson.build
@@ -1,17 +1,7 @@
1deps = [
2 cairo,
3 pango,
4 pangocairo,
5 wlroots
6]
7
8if gdk_pixbuf.found()
9 deps += [gdk_pixbuf]
10endif
11
12lib_sway_common = static_library( 1lib_sway_common = static_library(
13 'sway-common', 2 'sway-common',
14 files( 3 files(
4 'background-image.c',
15 'cairo.c', 5 'cairo.c',
16 'ipc-client.c', 6 'ipc-client.c',
17 'log.c', 7 'log.c',
@@ -21,6 +11,12 @@ lib_sway_common = static_library(
21 'stringop.c', 11 'stringop.c',
22 'util.c' 12 'util.c'
23 ), 13 ),
24 dependencies: deps, 14 dependencies: [
15 cairo,
16 gdk_pixbuf,
17 pango,
18 pangocairo,
19 wlroots
20 ],
25 include_directories: sway_inc 21 include_directories: sway_inc
26) 22)