summaryrefslogtreecommitdiffstats
path: root/common/meson.build
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2018-04-12 20:19:54 -0400
committerLibravatar Drew DeVault <sir@cmpwn.com>2018-04-12 20:19:54 -0400
commitcd1b32453a9296c18b28bff71607aeb22987b5cd (patch)
treec653c6d525b471914c01a9d7ae543f521b6138ed /common/meson.build
parentMerge pull request #1634 from aleksander/master (diff)
parentFix separator height calculation (diff)
downloadsway-cd1b32453a9296c18b28bff71607aeb22987b5cd.tar.gz
sway-cd1b32453a9296c18b28bff71607aeb22987b5cd.tar.zst
sway-cd1b32453a9296c18b28bff71607aeb22987b5cd.zip
Merge branch 'wlroots'
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/common/meson.build b/common/meson.build
new file mode 100644
index 00000000..44a29508
--- /dev/null
+++ b/common/meson.build
@@ -0,0 +1,23 @@
1lib_sway_common = static_library(
2 'sway-common',
3 files(
4 'background-image.c',
5 'cairo.c',
6 'ipc-client.c',
7 'log.c',
8 'list.c',
9 'pango.c',
10 'readline.c',
11 'stringop.c',
12 'unicode.c',
13 'util.c'
14 ),
15 dependencies: [
16 cairo,
17 gdk_pixbuf,
18 pango,
19 pangocairo,
20 wlroots
21 ],
22 include_directories: sway_inc
23)