summaryrefslogtreecommitdiffstats
path: root/client/meson.build
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2018-03-27 15:25:25 -0400
committerLibravatar Drew DeVault <sir@cmpwn.com>2018-03-28 14:25:19 -0400
commit632bb948b7ffbb08a6e965dabf88347afd0a1fa8 (patch)
treecbd9d4e4e3a7c605d2b0a5e3e66ce35554a74c4b /client/meson.build
parentAdd client protocols and swaybg skeleton (diff)
downloadsway-632bb948b7ffbb08a6e965dabf88347afd0a1fa8.tar.gz
sway-632bb948b7ffbb08a6e965dabf88347afd0a1fa8.tar.zst
sway-632bb948b7ffbb08a6e965dabf88347afd0a1fa8.zip
Add solid-color rendering to swaybg
Diffstat (limited to 'client/meson.build')
-rw-r--r--client/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/client/meson.build b/client/meson.build
new file mode 100644
index 00000000..597899ce
--- /dev/null
+++ b/client/meson.build
@@ -0,0 +1,21 @@
1deps = [
2 cairo,
3 pango,
4 pangocairo,
5 wlroots,
6 wayland_client,
7]
8
9if gdk_pixbuf.found()
10 deps += [gdk_pixbuf]
11endif
12
13lib_sway_client = static_library(
14 'sway-client',
15 files(
16 'buffer-pool.c',
17 ),
18 dependencies: deps,
19 link_with: [lib_sway_common],
20 include_directories: sway_inc
21)