summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2016-12-04 08:30:40 -0500
committerLibravatar GitHub <noreply@github.com>2016-12-04 08:30:40 -0500
commit5778c59a2f302071fd781683db57a97b51396c87 (patch)
treee0ec272832e88e6c8d92719efa70c6749452daff /CMakeLists.txt
parentFix memory leaks in swaybar (diff)
parentDisallow everything by default (diff)
downloadsway-5778c59a2f302071fd781683db57a97b51396c87.tar.gz
sway-5778c59a2f302071fd781683db57a97b51396c87.tar.zst
sway-5778c59a2f302071fd781683db57a97b51396c87.zip
Merge pull request #981 from SirCmpwn/security
Security features
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 83989ecd..e314fd73 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,9 +45,11 @@ option(enable-swaybar "Enables the swaybar utility" YES)
45option(enable-swaygrab "Enables the swaygrab utility" YES) 45option(enable-swaygrab "Enables the swaygrab utility" YES)
46option(enable-swaymsg "Enables the swaymsg utility" YES) 46option(enable-swaymsg "Enables the swaymsg utility" YES)
47option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES) 47option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES)
48option(enable-binding-event "Enables binding event subscription" YES)
49option(zsh-completions "Zsh shell completions" NO) 48option(zsh-completions "Zsh shell completions" NO)
50option(default-wallpaper "Installs the default wallpaper" YES) 49option(default-wallpaper "Installs the default wallpaper" YES)
50option(ld-library-path "Configures sway's default LD_LIBRARY_PATH" "/usr/lib")
51
52add_definitions(-D_LD_LIBRARY_PATH="${ld-library-path}")
51 53
52find_package(JsonC REQUIRED) 54find_package(JsonC REQUIRED)
53find_package(PCRE REQUIRED) 55find_package(PCRE REQUIRED)
@@ -83,9 +85,6 @@ if (enable-gdk-pixbuf)
83else() 85else()
84 message(STATUS "Building without gdk-pixbuf, only png images supported.") 86 message(STATUS "Building without gdk-pixbuf, only png images supported.")
85endif() 87endif()
86if(enable-binding-event)
87 add_definitions(-DSWAY_BINDING_EVENT=1)
88endif()
89 88
90include_directories(include) 89include_directories(include)
91 90