summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Tomáš Čech <sleep_walker@suse.com>2015-09-30 14:21:01 +0200
committerLibravatar Tomáš Čech <sleep_walker@suse.com>2015-09-30 14:21:01 +0200
commitc57499d29c06b0e8c1e682ad77f13bd421245808 (patch)
treebc3f7f2aa1a0b3350d37397d17444564fb8ca5b0 /CMakeLists.txt
parentreturn after disconnect ipc client and minor checks (diff)
downloadsway-c57499d29c06b0e8c1e682ad77f13bd421245808.tar.gz
sway-c57499d29c06b0e8c1e682ad77f13bd421245808.tar.zst
sway-c57499d29c06b0e8c1e682ad77f13bd421245808.zip
Use location of XKBcommon headers, don't expect build in source directory
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 09f37d6d..d8e4ebca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,6 +47,7 @@ include_directories(
47 ${WLC_INCLUDE_DIRS} 47 ${WLC_INCLUDE_DIRS}
48 ${PCRE_INCLUDE_DIRS} 48 ${PCRE_INCLUDE_DIRS}
49 ${JSONC_INCLUDE_DIRS} 49 ${JSONC_INCLUDE_DIRS}
50 ${XKBCOMMON_INCLUDE_DIRS}
50 include/ 51 include/
51) 52)
52 53
@@ -88,12 +89,12 @@ ADD_CUSTOM_TARGET(man ALL
88 DEPENDS ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/sway.5) 89 DEPENDS ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/sway.5)
89 90
90INSTALL( 91INSTALL(
91 FILES ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/sway.1 92 FILES ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/sway.1
92 DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man1 93 DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man1
93) 94)
94 95
95INSTALL( 96INSTALL(
96 FILES ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/sway.5 97 FILES ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/sway.5
97 DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man5 98 DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man5
98) 99)
99 100