summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Seth Barberee <seth.barberee@gmail.com>2016-01-17 22:06:26 -0600
committerLibravatar Seth Barberee <seth.barberee@gmail.com>2016-01-17 22:06:26 -0600
commitfcd007155552376fa5c482d5d650b90f9a7e172e (patch)
tree40a42c07547e9d7605577b6263cb4d182761ab2d /CMakeLists.txt
parentAdd ffmpeg/imagemagick to depenency list (diff)
downloadsway-fcd007155552376fa5c482d5d650b90f9a7e172e.tar.gz
sway-fcd007155552376fa5c482d5d650b90f9a7e172e.tar.zst
sway-fcd007155552376fa5c482d5d650b90f9a7e172e.zip
added basic zsh shell completion for sway, swaybg, and swaygrab
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 587c3dac..c63a88c7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,6 +45,7 @@ option(enable-swaygrab "Enables the swaygrab utility" YES)
45option(enable-swaymsg "Enables the swaymsg utility" YES) 45option(enable-swaymsg "Enables the swaymsg utility" YES)
46option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES) 46option(enable-gdk-pixbuf "Use Pixbuf to support more image formats" YES)
47option(enable-binding-event "Enables binding event subscription" YES) 47option(enable-binding-event "Enables binding event subscription" YES)
48option(zsh-completions "Zsh shell completions" YES)
48option(default-wallpaper "Installs the default wallpaper" YES) 49option(default-wallpaper "Installs the default wallpaper" YES)
49 50
50find_package(JsonC REQUIRED) 51find_package(JsonC REQUIRED)
@@ -117,7 +118,9 @@ if(enable-swaylock)
117 message(WARNING "Not building swaylock - cairo, pango, and PAM are required.") 118 message(WARNING "Not building swaylock - cairo, pango, and PAM are required.")
118 endif() 119 endif()
119endif() 120endif()
120 121if(zsh-completions)
122 add_subdirectory(completions/zsh)
123endif()
121install( 124install(
122 FILES ${CMAKE_CURRENT_SOURCE_DIR}/sway.desktop 125 FILES ${CMAKE_CURRENT_SOURCE_DIR}/sway.desktop
123 DESTINATION share/wayland-sessions 126 DESTINATION share/wayland-sessions