summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Christoph Gysin <christoph.gysin@gmail.com>2015-12-01 20:35:10 +0200
committerLibravatar Christoph Gysin <christoph.gysin@gmail.com>2015-12-01 22:03:09 +0200
commit2429266e3ec3c541d4eec10e6f828b422d056dbd (patch)
tree6df935435cc06683e7b17a0cb09f11606499736a /CMakeLists.txt
parentMerge pull request #284 from gpyh/master (diff)
downloadsway-2429266e3ec3c541d4eec10e6f828b422d056dbd.tar.gz
sway-2429266e3ec3c541d4eec10e6f828b422d056dbd.tar.zst
sway-2429266e3ec3c541d4eec10e6f828b422d056dbd.zip
cmake: convert all cmake commands to lowercase
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 68dd7fa3..c022d87d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,7 +8,7 @@ add_definitions('-DFALLBACK_CONFIG_DIR=\"${FALLBACK_CONFIG_DIR}\"')
8 8
9set(CMAKE_C_FLAGS "-g") 9set(CMAKE_C_FLAGS "-g")
10set(CMAKE_C_STANDARD 99) 10set(CMAKE_C_STANDARD 99)
11SET(CMAKE_C_EXTENSIONS OFF) 11set(CMAKE_C_EXTENSIONS OFF)
12set(CMAKE_CURRENT_BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/bin") 12set(CMAKE_CURRENT_BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/bin")
13set(CMAKE_RUNTIME_OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}") 13set(CMAKE_RUNTIME_OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}")
14add_definitions("-Wall -Wextra -Wno-unused-parameter -D_GNU_SOURCE") 14add_definitions("-Wall -Wextra -Wno-unused-parameter -D_GNU_SOURCE")
@@ -50,8 +50,8 @@ find_package(PCRE REQUIRED)
50find_package(Wayland REQUIRED) 50find_package(Wayland REQUIRED)
51find_package(JsonC REQUIRED) 51find_package(JsonC REQUIRED)
52 52
53FILE(GLOB sources ${PROJECT_SOURCE_DIR}/sway/*.c) 53file(GLOB sources ${PROJECT_SOURCE_DIR}/sway/*.c)
54FILE(GLOB common ${PROJECT_SOURCE_DIR}/common/*.c) 54file(GLOB common ${PROJECT_SOURCE_DIR}/common/*.c)
55 55
56include(Wayland) 56include(Wayland)
57WAYLAND_ADD_PROTOCOL_SERVER(proto-desktop-shell "${PROJECT_SOURCE_DIR}/protocols/desktop-shell.xml" desktop-shell) 57WAYLAND_ADD_PROTOCOL_SERVER(proto-desktop-shell "${PROJECT_SOURCE_DIR}/protocols/desktop-shell.xml" desktop-shell)