summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Drew DeVault <sir@cmpwn.com>2015-11-30 19:16:47 -0500
committerLibravatar Drew DeVault <sir@cmpwn.com>2015-11-30 19:16:47 -0500
commit3075b4a61debb123c85bb1aa6a7a16190ba3c0ad (patch)
tree4a9ecf5416f6e109f60aa6834eec43cba5267d5d /CMakeLists.txt
parentAdd framework for switching command sets (diff)
parentCan customize config fallback directory (diff)
downloadsway-3075b4a61debb123c85bb1aa6a7a16190ba3c0ad.tar.gz
sway-3075b4a61debb123c85bb1aa6a7a16190ba3c0ad.tar.zst
sway-3075b4a61debb123c85bb1aa6a7a16190ba3c0ad.zip
Merge pull request #281 from gpyh/master
Can customize fallback config directory
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1298a2ce..9e1e1dde 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,9 @@ cmake_minimum_required(VERSION 3.1.0)
2 2
3project(sway C) 3project(sway C)
4 4
5set(FALLBACK_CONFIG_DIR "/etc/sway/")
6add_definitions('-DFALLBACK_CONFIG_DIR=\"${FALLBACK_CONFIG_DIR}\"')
7
5set(CMAKE_C_FLAGS "-g") 8set(CMAKE_C_FLAGS "-g")
6set(CMAKE_C_STANDARD 99) 9set(CMAKE_C_STANDARD 99)
7SET(CMAKE_C_EXTENSIONS OFF) 10SET(CMAKE_C_EXTENSIONS OFF)
@@ -80,7 +83,7 @@ install(
80 COMPONENT runtime) 83 COMPONENT runtime)
81install( 84install(
82 FILES "${CMAKE_CURRENT_SOURCE_DIR}/config" 85 FILES "${CMAKE_CURRENT_SOURCE_DIR}/config"
83 DESTINATION /etc/sway/ 86 DESTINATION "${FALLBACK_CONFIG_DIR}"
84 COMPONENT configuration) 87 COMPONENT configuration)
85 88
86add_custom_target(man ALL) 89add_custom_target(man ALL)