summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Hummer12007 <hilobakho@gmail.com>2017-07-03 23:30:39 +0300
committerLibravatar GitHub <noreply@github.com>2017-07-03 23:30:39 +0300
commitc8370c96991cb8af647e46e5067b6c6641eacec4 (patch)
tree9e3f94462da0dd840cf50c7a724145e6d5b5473c /CMakeLists.txt
parentMerge pull request #1258 from refacto/fix_zsh_completion (diff)
downloadsway-c8370c96991cb8af647e46e5067b6c6641eacec4.tar.gz
sway-c8370c96991cb8af647e46e5067b6c6641eacec4.tar.zst
sway-c8370c96991cb8af647e46e5067b6c6641eacec4.zip
Disable -Wunused-result diagnostic
It caused unpredictable build failures with different build environments
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0257a99f..a4bf351b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,7 @@ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/bin)
10set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall") 10set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
11set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wextra") 11set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wextra")
12set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-unused-parameter") 12set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-unused-parameter")
13set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-unused-result")
13set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror") 14set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror")
14if (CMAKE_COMPILER_IS_GNUCC) 15if (CMAKE_COMPILER_IS_GNUCC)
15 if(NOT CMAKE_C_COMPILER_VERSION VERSION_LESS 7.0) 16 if(NOT CMAKE_C_COMPILER_VERSION VERSION_LESS 7.0)