summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLibravatar Mikkel Oscar Lyderik <mikkeloscar@gmail.com>2016-01-09 20:25:05 +0100
committerLibravatar Mikkel Oscar Lyderik <mikkeloscar@gmail.com>2016-01-09 20:25:45 +0100
commit93c93dd0f7aa27fc31702bd91f055f5bac45fe3c (patch)
tree71dc21b74fd0287f66ceed965fb0d96cbfe17aa6 /CMakeLists.txt
parentMerge pull request #442 from mikkeloscar/bincode (diff)
downloadsway-93c93dd0f7aa27fc31702bd91f055f5bac45fe3c.tar.gz
sway-93c93dd0f7aa27fc31702bd91f055f5bac45fe3c.tar.zst
sway-93c93dd0f7aa27fc31702bd91f055f5bac45fe3c.zip
Make enable-binding-event option have an affect.
The option was added to late so it was never set in the build.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2924c3e4..587c3dac 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -79,6 +79,9 @@ if (enable-gdk-pixbuf)
79else() 79else()
80 message(STATUS "Building without gdk-pixbuf, only png images supported.") 80 message(STATUS "Building without gdk-pixbuf, only png images supported.")
81endif() 81endif()
82if(enable-binding-event)
83 add_definitions(-DSWAY_BINDING_EVENT=1)
84endif()
82 85
83include_directories(include) 86include_directories(include)
84 87
@@ -114,9 +117,6 @@ if(enable-swaylock)
114 message(WARNING "Not building swaylock - cairo, pango, and PAM are required.") 117 message(WARNING "Not building swaylock - cairo, pango, and PAM are required.")
115 endif() 118 endif()
116endif() 119endif()
117if(enable-binding-event)
118 add_definitions(-DSWAY_BINDING_EVENT=1)
119endif()
120 120
121install( 121install(
122 FILES ${CMAKE_CURRENT_SOURCE_DIR}/sway.desktop 122 FILES ${CMAKE_CURRENT_SOURCE_DIR}/sway.desktop